I have an older macOS version. Can I still use Sound Studio 4?

Yes. The latest version of Sound Studio 4 requires macOS 10.8 or later. If you have an older macOS version, check our Archive for compatible older versions of Sound Studio. Note that these older versions are unsupported and we can't make any changes or updates to them.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.