What are the system requirements for Sound Studio 4?

Sound Studio 4 requires OS X Mavericks (10.9) or later. Please see our Technical Specifications page for details on minimum system requirements, supported file formats, and other details.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.